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Executive Summary 
 

This final project report describes CPFLOW (Continuation Power Flow), a comprehensive 
software tool for tracing power system steady-state behaviors due to large or small variations in 
loads, generation, transactions, interchanges, and imports and exports. CPFLOW is designed for 
the analysis of large-scale power systems and can trace a solution curve through the ‘nose’ point 
without the numerical difficulties of repeated power flow solvers. It can generate P-V, Q-V, and 
P-Q-V solution curves by varying any combination of: 

• bus P and/or Q loads plus real power generation at P-V buses 
• area P and/or Q loads plus real power generation at P-V buses 
• system P and/or Q loads plus real power generation at P-V buses 
• power interchanges 
• power transactions 
• power imports or exports. 

 
CPFLOW can be used in a variety of applications such as:  

• monitoring voltage behaviors due to load and generation variations to detect such problems 
as voltage dip and collapse 

• evaluating maximum interchange capability 
• evaluating maximum available transfer capability 
• tracing of power system behaviors due to load and/ generation variations with/without 

control devices 
• conducting coordination studies of control devices for steady-state security enhancements 
• evaluating the effects of different load models on voltage stability, transfer capability 

among other system condition variables of interest. 
 
CPFLOW supports power system analysis of the following transactions and transmission 
services: 

• Point-to-point MW transactions 
• Slice-of-the-system sales 
• Network service. 

 
CPFLOW has several advantages over repetitive power flow solvers. It is more reliable in 
obtaining the solution curve, especially for ill-conditioned power flow equations. It is faster 
through its use of an effective predictor, adaptive step-length selection, and efficient I/O 
operations. Finally, CPFLOW is more versatile. It uses parameterizations that give the user the 
flexibility to easily analyze changes in real and/or reactive loads, and in real generation at P-V 
buses.  
 
The program works with Windows 95 or later and Windows NT 3.51 or later. It is able to 
process power systems with up to 32,627 buses. 
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Chapter 1 
Overview of CPFLOW 

This final project report describes CPFLOW (Continuation Power Flow), a comprehensive 
software tool for tracing power system steady-state behaviors due to large or small variations in 
loads, generation, transactions, interchanges, and imports and exports. CPFLOW can generate P-
V, Q-V, and P-Q-V curves with the ability to vary a combination of the following: 

• general bus (P and/or Q) loads plus real power generations in P-V buses 
• area (P and/or Q) loads plus real power generations in P-V buses 
• system (P and/or Q) loads plus real power generations in P-V buses 
• power interchanges 
• power transactions 
• power import or export. 

 
CPFLOW is designed for the analysis of large-scale power systems in order to trace the solution 
curve through the ‘nose’ point without any numerical difficulty. The main advantages of 
CPFLOW over repetitive power flow solvers are: 

• Reliability: CPFLOW is more reliable than repeated power flow solvers in obtaining the 
solution curve, especially for ill-conditioned power flow equations; 

• Speed: CPFLOW is faster than the repeated load flow approach through the use of an 
effective predictor, an adaptive step-length selection, and efficient I/O operations; and 

• Functionality: CPFLOW is more versatile than repeated power flow solvers due to the use 
of parameterizations such that general bus real and/or reactive loads, area real and/or 
reactive loads, or system-wise real and/or reactive loads, and real generations in P-V buses 
(e.g., those determined by economic dispatch or participation factor) can vary. 

1.1 Applications of CPFLOW 
CPFLOW can be used in a variety of applications such as:  

• the monitoring of voltage behaviors due to load and generation variations to detect 
problems such as voltage dip and voltage collapse  

• the evaluation of maximum interchange capability 
• the evaluation of maximum available transfer capability 
• the tracing of power system behaviors due to load and/ generation variations with/without 

control devices 
• coordinate studies of control devices for steady-state security enhancements. 
• the evaluation of the effect of different load models on voltage stability, transfer capability, 

and so on. 
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CPFLOW supports one or several of the following power transactions and transmission services: 
• Point-to-point MW transactions - the real power at one load bus of the receiving area varies 

while the others remain fixed and the real power at one generator bus of the sending area 
varies while the others remain fixed; 

• Slice-of-the-system sales - both the real and reactive power demands at a load bus of the 
receiving area vary and the real power generation at some collection of generators of the 
sending bus varies while the others are fixed; and 

• Network service - the real and/or reactive power demands at some collection of load buses 
of the receiving area vary and the real power generation at some collection of generators of 
the sending bus varies while the others are fixed. 

1.2 Modeling Capability  
CPFLOW simulates realistic operating conditions or expected future operating conditions under 
proposed multiple power transactions. To this end, the activation of control devices and the 
accurate representation of power transactions are included in the simulations. The control 
devices include: (i) switchable shunts and static VAR compensators, (ii) ULTC transformers, 
(iii) ULTC phase shifters, (iv) static tap changers and phase shifters, (v) DC networks. In order 
to completely describe the actual power flow in the interconnected systems and, in particular, the 
parallel flows on adjacent systems, a detailed nonlinear power flow analysis of the 
interconnected system must be performed.  
 
CPFLOW has a range of modeling capabilities, as described below. 
 
1. Generators  
 
Generators are modeled as active and reactive power sources that also provide voltage control. 
The MVAR output of each on-line generator is adjusted during power flow solutions in order to 
control the voltage of the local bus (the bus where the generator is connected) or a remote bus. 
The generator's MVAR output has fixed limits.  
 
2. Base Case Loads 
 
Loads can be modeled as constant power (P-Q), constant current (I), constant impedance (Z) or 
any linear combination thereof. The tool can also accept nonlinear load models as long as they 
are expressed as nonlinear functions of voltage. 
 
3. Load Variation 
 
In the traditional CPFLOW program, the load variation (increment) is modeled as constant P-Q 
load, which usually yields conservative result. In this new program version, a user can select 
different combinations of ZIP load models for the proposed load variations and evaluate the 
system’s stationery behavior under the proposed load model.  
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4. Control Devices  
 
The following control devices are modeled: 

• Switchable shunts and static VAR compensators 
• Interchange schedules 
• ULTC transformers 
• ULTC phase shifters 
• Static tap changers and phase shifters 

 
5. DC Network (up to 25 DC transmission lines) 
 

1.3 Input Data Format 
CPFLOW can import power flow data in the following formats: 

• EPRI  
• BPA  
• IEEE  
• PECO  
• PTI. 

 
The current GUI version of CPFLOW only supports PTI raw data input. The current production 
version of CPFLOW can handle power systems of up to 32,627 buses.  
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Chapter 2  
Technical Description of CPFLOW 

2.1 Introduction 
This chapter provides a technical description of CPFLOW. In addition, CPFLOW has been 
extended for the generation of ZIP-V curves for tracing power system steady state behavior due 
to load and generation variations. This chapter describes this extension, too. 
 
Load models are known to have profound impacts on power system behaviors. It is well-
recognized that the constant P-Q load model leads to unsatisfactory simulation results of power 
system static behaviors. This is due to the assumption of fixing power demands for varying 
operating conditions. The commonly-used nonlinear load model, the ZIP-model (which 
combines loads of constant current, constant power, and constant impedance), is popular for 
modeling the nonlinear behaviors of loads. The ZIP-model often leads to accurate results in 
simulating power system static behaviors. 
 
P-V, Q-V, and P-Q-V curves have been widely used to analyze power system behavior under 
varying loading conditions. Voltage stability and loadability analyses are examples of the 
application of these curves in power system analysis. These curves are obtained, during varying 
loading/generation conditions, under the assumption that the constant P-Q lead component of a 
bus (or a collection of buses) varies, with the constant current load and constant impedance load 
being kept indeed “constant”. Even though the physical meaning of these curves can be readily 
explained and these curves serve their purpose well, they tend to be on conservative in predicting 
system limits such as voltage stability or loadability limit. Since the ZIP-model is so popular, it 
makes the most sense to allow the components constant current load and constant impedance 
load to vary as well to model load variation in power systems. 
 
We do not to evaluate the assumption of fixing the values of constant current loads and constant 
impedance loads in generating the P-V curve, Q-V curve, or P-Q-V curves; instead, we show that 
the assumption can be relaxed and a new class of curves, called ZIP-V curves, can be generated. 
ZIP-V curves represent power system quasi-steady-state behaviors as all the values of constant 
Z, I ,P-Q (ZIP) vary and their variations are uniform. The ZIP-V curve can become an I-V, Z-V, 
IP-V, ZP-V or IZ-V curve when the values of the corresponding component are kept constant. A 
new set of parameterized power flow equations is proposed. An extension to CPFLOW is used to 
generate illustrative ZIP-V curves. 

2.2 CPFLOW with ZIP Load Variation 
Let Pi ≡ Pgi - Pdi and Qi ≡ Qgi - Qdi. The lowercase g represents generation and the lowercase d 
represents load demand. The set of power flow equations can be represented in compact form as: 
 

( ) ( )
( ) ,0=








−
−

=
QxQ
PxP

xf  where ( )θ,Vx =  
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Parameters can be added to these equations to investigate the steady-state behavior of the power 
system under slow variation of both loading conditions and real power redispatches. For 
example, to trace the power system state from the base-case load-generation condition [Pd

0, Qd
0, 

Pg
0] to a new load-generation condition [Pd

1, Qd
1, Pg

1], then the following parameterized power 
flow equations can be formed: 
 

 F(x,λ) ≡ f(x)-λb = 0 (2-1) 

 
where the load-generation vector b is 
 

 








−
−

≡ 01

01

QQ
PP

b  (2-2) 

 
It follows that the parameterized power flow equations (2-1) become the base-case power flow 
equations when λ = 0 so that 
 

 ( ) ( )
( )

00, 0

0

=








−
−

=
QxQ
PxP

xF  (2-3) 

 

When λ = 1, the parameterized power flow equations (2-1) simulate the static behaviors of the 
power system at the new load-generation condition [Pd

1, Qd
1, Pg

1], as described by  
 

 ( ) ( ) ( )
( )

01, 1

1

=








−
−

=−=
QxQ
PxP

bxfxF  (2-4) 

 
As shown in the above procedure, we can investigate the effects of varying real power 
generations as well as varying load demands on power system steady-state behaviors by 
analyzing the set of parameterized power flow equations (2-1). In fact, we can parameterize any 
change in PQ loads in conjunction with any change in P generations by selecting an appropriate 
vector b. 
 
Repetitive power flow calculations are frequently used to investigate potential voltage stability 
problems with respect to a given parameter increase pattern. The calculations generate the so-
called P-V or Q-V curve along the parameter increase direction. With this approach, an operating 
point is claimed to be the potential voltage instability/collapse point if it is the first point (along 
the parameter increase direction) at which the power flow equations do not converge.  
 
Several issues arise regarding the use of repetitive power flow calculations. First, the point where 
the power flow calculations diverge (which is determined by a numerical failure) does not 
necessarily represent the maximum loading point (or transfer capability point) of the power 
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system, which is a physical limitation of the system. In fact, the maximum loading point should 
be determined based on the physical limitation of the underlying power network configuration, 
the loading condition, the parameter increase direction, etc. The point should not be determined 
based solely on the mathematical limitation of a numerical method.  
 
Second, the point where power flow calculations fail to converge may vary depending on which 
numerical method was used to solve the power flow equations. For instance, it is likely that the 
point where the Newton method fails to converge is different from the point where the coupled-
Newton method fails to converge. 
 
It is known that the set of power flow equations is ill-conditioned near its “nose point,” making 
the Newton method diverge in the neighborhood of nose points. From the viewpoint of 
numerical analysis, this is due to the fact that, at the nose point (i.e., the saddle-node bifurcation 
point), the Jacobian matrix has one zero eigenvalue, thus causing the set of power flow equations 
to be ill-conditioned.  
 
Recently, considerable progress has been made in generating P-V and Q-V curves using an 
approach based on continuation methods (continuation power flow). Continuation methods, 
sometimes called curve tracing or path following, are useful tools to generate solution curves for 
general nonlinear algebraic equations with a varying parameter. CPFLOW was designed to make 
calculations using continuation methods. Continuation methods overcome the numerical 
difficulty of ill-conditioning as described below. 
 
First, we treat λ as another state variable: 
 

 λ=+1nX  (2-5) 

 
Then, we introduce a new parameter s; the mathematical meaning of s is the arc length on the 
solution curve, which is defined as follows: 
 

 ( )( ) ( )∑
+

=

∆=−
1

1

2
n

j
jj ssxx  (2-6) 

 
It can be shown that the new set of equations (2-1) and (2-6) is numerically well-conditioned, 
even at the nose point. CPFLOW solves these augmented power flow equations to obtain a 
solution curve passing through the nose point without encountering the numerical difficulty of 
ill-conditioning. 
 
When one applies the continuation method to the parameterized power flow equation (2-1) to 
compute P-V curves, only the constant PQ portion of a load varies, while the constant current 
portion and constant impedance portion are indeed kept “constant.” As such, the physical 
meaning of these curves may be easily explained but the load model may not be accurate. Load 
models are known to have significant impacts on simulating power system behaviors. In order to 
accurately characterize the voltage behavior of a power system, it is necessary to use accurate 
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load models in the computation of P-V and Q-V curves. For a power system of n buses, the 
equations for the ith bus can be expressed as: 
  

( ) ( )

( ) ( )









=∆−∆++−

=∆−∆++−

∑

∑

=

=
n

j
ligiijijijijjii

n

j
ligiijijijijji

QQBGvvQ

PPBGvvP

1
0

1
01

0cossin

0sincos

λδδ

λδδ
 (2-7) 

 
where Poi and Qoi are the base-case real and reactive power injections at bus i respectively. vi is 
the voltage magnitude at bus i. Gij and Bij are the real part and imaginary parts of the network 
admittance between bus i and bus j respectively. δij is the angle difference between bus i and bus 
j. ∆ Pg  is the proposed real generation variation at bus i. ∆ Qgi,, the proposed reactive generation 
variation at bus I, is a kept constant. Finally, ∆ Pli and ∆ Qli are the proposed real and reactive 
load variations at bus i. 
 
Without losing generality, equation (2-7) can be rewritten in the following form:  
 

 
( )

( )



=∆−
=∆−∆+

0,
0,

qq

ppp

Lvf
LGvf

λδ
λλδ

 (2-8) 

 
where fp(δ, v), fq(δ, v) ∈ Rn are the set of base-case power flow equations. ∆GP ∈ Rn is a 
proposed real generation variation. ∆Lp, ∆Lq ∈ R2n are the proposed real and reactive load 
variations respectively. 
 
We now model the load variation as a composition of ZIP (constant impedance, constant current, 
and constant PQ) format and this composition keeps constant during the process of load 
variation. Using this ZIP model, the load variation is modeled as follows:  
 

 






++=∆
++=∆

qqqq

pppp

avavaL
avavaL

32
2

1

32
2

1  (2-9) 

 
where a1p, a2p, a3p, a1q, a2q, a3q ∈ R n x n are diagonal coefficient matrices and represent the 
constant impedance, constant current and constant PQ portion respectively of the load variation 
and v ∈ Rn is the voltage magnitude vector. 
 
Substituting (2-9) into (2-8), we have the following new set of parameterized power flow 
equations with parameter variations modeled by ZIP variations 
 

 
( ) ( )

( ) ( )





=++−
=++−∇+

0,
0,

32
2

1

32
2

1

qqqq

ppppp

avavavf
avavaGvf

λδ
λλδ

 (2-10) 
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It is traditional to have only the constant PQ load component vary but keep the load components 
of constant impedance and constant current fixed. In this case, the coefficient matrices a1p, a1q 
and a2p, a2q become zero matrices and the new set of parameterized power flow equations (2-10) 
is reduced to the traditional set of parameterized power flow equations (2-2). 
 
We next show how to apply CPFLOW to solve the new set of parameterized power flow 
equations (2-10). Combining equation (2-10) and (2-6) gives the following augmented 
(parameterized) power flow equations: 
 

 
( ) ( )

( )( ) ( )





∆=−

=++−∆+

∑
+

=

1

1

22

32
2

1 0,
n

J
jj ssxx

avavaGvf λλδ
 (2-11) 

 
where 
 









=








=

q

p

q

p

a
a

a
a
a

a
2

2
2

1

1
1 , and 








=

q

p

a
a

a
3

3
3  

( ) ( )
( ) 








=








=

0
,

,
,

, p

q

p G
G

vf
vf

vf
δ
δ

δ  

 
Solving equations (2-11) produces the desired ZIP-V curves.  

2.3 Numerical Solution Using CPFLOW 
In this section we describe CPFLOW’s numerical approach to solving power flow equations and 
show how to modify the original CPFLOW program to solve the new set of parameterized power 
flow equations (2-11). 

2.3.1 Predictor 
The predictor in CPFLOW is used to find the approximation of the next point in the solution 
curves. CPFLOW uses two predictor approaches: secant and tangent. The secant method, 
extrapolating the next solution point based on the previous solution points in the solution curve, 
is not affected by the load model used in the computation. The tangent method, using the tangent 
at the current point to predict the next solution point, is affected by the load model used. 
 
We define the power flow state variable vector X as follows: 
 

X = [δ1, …, δ1, v1, … vn, λ]T 
 
Differentiating with respect to the arc length s, we have: 
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



=

ds
d

ds
dv

ds
dv

ds
d

ds
d

ds
dX nn λδδ ;,...,,..., 11  

 
where arc length is defined as: 
 

∆X• 〈∆X 〉T = (∆s)2 
 
Differentiating both sides of the equation (2-11), it follows that: 
 

 0=•
ds
dXD  (2-12) 

 




∂
∂

= CBfD
δ

 (2-13) 

 
where 
 

( )λaVa
v
fB +−

∂
∂

= 12 ( )32
2

1 aVaVaGC ++−∆=  









∂
∂

∂
∂

=
∂
∂

nv
f

v
f

v
f ...

1

 









∂
∂

∂
∂

=
∂
∂

n

fff
δδδ

...
1

 

 
and nnRV ×∈  is a diagonal matrix of voltage magnitude at each bus. 
 
The following equation is required to ensure that the scalar s is the arc length on the solution 
curve: 
 

 1=



•

T

ds
dX

ds
dX  (2-14) 

 

The tangent vector along the solution curve 
ds
dX  is obtained by solving the set of equation (2-

12), (2-13) and (2-14). 
 
The predicted vector at the next solution point 1+iX  by the tangent method becomes: 
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ds

dX
hXX i

ii +=+1  (2-15) 

 
where h is the step size of arc length s, Xi is the ith solution in the solution curve 

2.3.2 Corrector 
The corrector solves the augmented equations with the predicted point as the initial guess. In 
principle, any effective numerical procedure for solving a set of non-linear algebraic equations 
can be used for a corrector. In CPFLOW, we use the Newton-Raphson method in which the 
system Jacobian matrix plays an important role. 
 
To accommodate the ZIP load model in the load variations, we derive the Jacobian matrix 
considering ZIP load variation as follows: 
 









=

E
D

J  

 
D is given in (2-13) and E is 
 

( )( )TsXXE −= 2  

 
Note that the required modifications only appear on the diagonal elements and the arc length s 
related elements. 
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Chapter 3 
Basic Instructions for Using CPFLOW 

This chapter provides basic instructions for the use of the CPFLOW program, Version 4.1. We 
assume that the reader has a basic working knowledge of Windows operating system 
conventions, including how to use a mouse and standard menus and commands, and how to 
open, close, and save files. For help with any of these techniques, the reader can refer to the 
documentation that accompanied the computer or a manual for Windows. 

3.1 Installation 

3.1.1 System requirements 
1. A PC with Windows 95 or later, Windows NT 3.51 or later 
2. A minimum of 10 MB hard disk space, 32 MB physical memory  

3.1.2 Packing List  

1. System files: 
• CPGUI.EXE: Main program 
• CPGUI.INI: Configuration file 
• PSYM: Symbol file 
• PSYM.IDX: Symbol file 
• ATC.DOC: Manual File 

 
2. Sample project files: 

• IEEE50.psf: Power flow Data file 
• IEEE50.pwr: Project file with One-line diagram 

 
3. Sample power system data file: 

• IEEE50 power system data file in PTI format 

3.1.3 Installation Procedure 

1. Create directory C:\CPGUI.  
2. Copy cpgui.zip to C:\CPGUI and use PKUNZIP to expand it. 
3. Copy cpgui.ini to C:\WINDOWS or C:\WINNT (depending on your operating system). 
 
If you install the system files in a directory other than C:\CPGUI, follow the steps below to 
adjust the configuration: 
 
1. Create the directory where you want to put the system files. 
2. Copy cpgui.zip to that directory and use PKUNZIP to expand it. 
3. Use any text editing tool to edit cpgui.ini and change the “system path” from C:\CPGUI\ to 

the directory where you want to put the files. 
4. Copy cpgui.ini to C:\WINDOWS or C:\WINNT (depending on your operating system). 



 

 12

3.2 System Settings 

3.2.1 Power Flow Setting 
Selecting the menu item "Power Flow Setting" under "Analysis" pops up the following setting 
dialog box: 
 

 
Figure 3.1  The System Analysis Setting panel 

 
This dialog box provides a basis panel for a user to change basic computation parameters such as 
the solution algorithm (currently only Newton Raphson is available), control model, and 
convergence criterion. From this panel, the user can ask the program to conduct a regular power 
flow computation or a CFLOW computation. Users can also activate or deactivate a particular 
control mode by checking or unchecking the corresponding check box. Furthermore, users can 
enter the desired values for fields such as convergence criterion, maximal iteration number, 
voltage violation criterion, etc.  
 
Some of the parameters on this panel are defined as follows: 

• Max iterations: the maximum number of iterations involved in solving a single power flow 
solution point. 

• Tolerance (MW or MVAR): the maximum MW or MVAR mismatch allowed for each bus 
in solving a single power flow solution point.  

• Acceleration factor: the multiplier that is used to reduce the change in voltage magnitude 
when a bus is switched between PQ type to PV. This is useful for avoiding oscillations. 
This multiplier is not used in conjunction with any other control device. 
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• Blow up (delta v): the maximum update in voltage magnitude allowed for any bus. If the 
largest update is greater than this preset value, then power flow computation terminates in a 
nonconvergent state. 

• Zero impedance threshold: the minimum absolute value allowed for each complex line 
impedance in the power system. If a line impedance magnitude is less than the threshold, 
then the line is removed and the two buses are combined into a single bus. 

3.2.2 CPFLOW Setting 
A dialog box to configure CPFLOW is activated by clicking on the button reading "CPFLOW 
Setting" in the above panel.  

 
Figure 3.2  The CPFLOW Setting Panel 

 
 
Some of the most important parameters are explained as follows: 

• minimum lambda value: the minimum value for the physical parameter λ. If λ runs smaller 
than λmin during a CPFLOW computation, the continuation method terminates. 

• maximum lambda value: the maximum value for the physical parameter λ. If during a 
continuation run λ>λmax, then the continuation method terminates. 

• maximum number of steps: the maximum number of steps allowed in a continuation trace. 
If the maximum number is reached, then the trace terminates. 

3.2.3 P-V Curve Setting 
The dialog box to configure P-V curves is triggered by clicking on a button reading “Curve 
Setting” in the CPFLOW setting panel. Through this panel, a user can tell the program how to 
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chose the X-axis when plotting a P-V curve. The first two options tell the program to use λ as the 
X-axis. At this time, they are identical. While the third option instructs the program to use the 
total generation, the last option uses the total load of the examined power system as the X-axis of 
the P-V curve. 
 

 
Figure 3.3 The P-V curve setting panel 

3.3 Running CPFLOW 
In this section, we will provide a demonstration of the working of CPFLOW Version 4.1. A 
detailed explanation of each step is given. 

3.3.1 Running the Test Program 
1. Launch CPGUI.exe. 
2. FILE-OPEN-select 97f3a.. 
3. Click on the “Map” icon at the top of the screen to bring up a panoramic map view of the 

system one-line diagram. 
4. Grab the red box displayed within the map picture and move it around to pan across the 

system one-line diagram and examine its details more closely. 
5. To set up a transaction: 
 a. ANALYSIS—CPFLOW INITIAL—SET TRANSACTION—DIALOG BOX 

--BY AREA (Transactions within an area) 
--BY BUS (Bus-to-Bus transactions) 
--BY TRANSACTION (Transactions between areas) 

(Select BY TRANSACTION and do a 5000 MW transaction from area 5 to area 63 as 
follows: first, enter 5000 in the box labeled P and enter nothing in the box labeled Q. To 
send in the area, enter 5. In the next box, select GENERATION. To receive an area, enter 
63. In the last box, select LOAD. Make sure that Q Proportional is checked. Make sure 
that the three fields under the heading load model group are 1,0,0 respectively. This setup 
will initiate a transaction from area 5 to area 63 by raising generation in area 5 and 
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synchronously increasing load in area 63. The process is done while maintaining a 
constant power factor on the load side. Click on OK.) 

 
b. ANALYSIS—CPFLOW INITIAL—SET MONITOR—FROM DIALOG BOX 
(This sets up buses to monitor during the process) 
Enter 37742,37743 (for bus 37742,37743) and select OK 
 
c. ANALYSIS—RUN ANALYSIS (to execute). Click on START in the Procedure 

Monitor box to start the program. 
 
While the program is running you will notice two curves forming in the PV Curve box. These are 
the nose curves for bus 37742,37743. The “x’s” are voltage violation points for the system. 
When the program is done (that is, when the thermometer has filled up in the procedure Monitor 
box), the nose of the curve is at 0.8, indicating that 0.8*5000 or 4000 MW is the max power 
transfer under the transaction that was entered. Even though bus 37748 was selected as an 
example, the max transfer point is the same for the system regardless of what bus is monitored 
and the voltage violations occur at the same transfer point regardless of what bus is monitored. If 
the user makes the PV-curve box larger and double-click on any of the X’s, the voltage violation 
that occurs at that transfer level can be seen. 

3.3.2 Import PTI Raw Data File 
1. Select a data format under the submenu "import data" of the menu "File" to start an import 

dialog box. For example, import a data file in PTI format: 

 
Figure 3.4  The panel for importing a PTI raw data file 

 
2. Open the desired PTI file. 
3. Follow the instructions to input the system scope. 
 
Note: The import PTI file function only works before a project is loaded. The program 
automatically generates a project with the same name as the imported PTI file, so that the next 
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time only the generated project needs to be opened instead of re-importing the PTI file. In our 
current setting, a pwr file and a psf file with the same name (different extensions) make a project. 

3.3.3 Generating PV, Q-V, and ZIP-V Curves due to Power Transactions 
1. Set a power transaction’s detailed setting 
 

Select a Menu item under menu "Analysis"->"CPFLOW INITIAL"->"SET 
TRANSACTION->DIALOG BOX". A dialog box pops up: 
 

 
Figure 3.5  Setting up a proposed power transaction 

 
The list box to the left lists various forms of power transactions that are supported in the 
program that this system can set. Pointing and clicking on the desired transaction type 
activates the corresponding fields for users to specify the desired power transaction. 

 
A user can select one or a combination of the three transaction types which are listed in 
the list box to set transactions. In the program, a transaction is comprised of a set of a 
certain number of real (and /or reactive) power increases (and/or decreases) on one or a 
collection of loads (and/or generators). The design of three transaction types in the dialog 
box provides users with the necessary convenience to enter the desired transaction 
quickly. 

 
The details of each transaction type are as follows:  

 
1. Selecting "BY BUS" offers a user the possibility to enter the desired power change for 

each bus. A user can specify the bus name, the amount of the power change and the way 



 

 17

to change power (increase generator or decrease load) on each particular bus or bus 
collection through the fields to the right. 

2. Selecting "BY AREA" offers a user the capability to enter the desired power change for 
specific areas. A user can specify the area number, the amount of the power change and 
the way to change power (increase generator or decrease load) for one area or area 
collection through the fields to the right, if the actual power changes for each bus within 
the desired areas are uniform. The economic dispatch function is not included. 

3. Selecting "BY TRANSACTION" offers a user the ability to enter a complete transaction 
(for example, transfer 300 MW power from area A to Areas B, C, D) in one step. A user 
can specify the sending areas, receiving areas, amount of power transfer and the way to 
change power (increase generator or decrease load) through the fields to the right, if the 
actual power changes for each bus within the involved areas are uniform. The economic 
dispatch function is not included. 

 
For example, we select "BY TRANSACTION". The dialog box changes to the following 
form: 

 

Figure 3.6  The complete transaction panel under “BY TRANSACTION” 
 

On the right, there are seven fields. 
• The first field allows the user to enter the total amount of transferred real power. 
• The second field allows the user to enter the total amount of transferred reactive 

power. 
• The third field allows the user to enter sending areas. Multiple areas can be input, 

separated by commas. 
• The fourth field allows the user to enter the way for the sending area to support the 

transaction. There are two available options: Generation and Load. Choosing 
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Generation tells the system to increase the generation at the sending areas to support 
the transaction. Choosing Load tells the system to decrease the load at the sending 
areas so that the surplus generation can be used to support the transaction. 

• The fifth and sixth fields are used to enter the information about the receiving areas. 
• The seventh field is used to instruct the system on how to handle the reactive power. If 

this field is checked, the program changes the reactive power proportionally to the real 
power no matter what value was input in the second field. Otherwise, the program 
uses the Q value input in the second field to change the reactive power. 

 
Now we will discuss the check box "Q Proportional." This check box offers the user a 
way to handle proposed reactive power changes flexibly. If this box is checked, the 
proposed reactive power change will be conducted proportionally to the proposed real 
power change no matter what value the user enters in the Q field. Otherwise, the program 
will use the value in the Q field to propose the reactive power change. 

 
The Q transaction only works for load changes. It represents the Q limit for the 
generation change, which can be seen from the transaction window after you click OK 
from the set transaction dialog box. The proposed reactive power change for a generator 
is thus actually a proposed reactive power limit change in the analysis. We do not 
maintain the power factor for a generator. 

 
The current version of the program does not support the real power limit for a generator. 
This will be incorporated into a future version of CPFLOW. 
 
The three fields in the left lower area are new and are used to enter a load model to 
generate ZIP-V curves for the involved load variation. These three fields respectively 
represent the portion of constant PQ load, portion of constant current load, and constant 
impedance load. Adding this new area in this window is intended to offer a convenient 
and straightforward way for a user to enter a desired load model for involved load 
variations. It does not mean that different load models can be set for different transactions 
within a simulation scenario. Only the last load model entered is accepted and takes 
effect on all of the load variations involved within a single scenario.  
 

1. Repeat step 1 to set simultaneous transactions. 
2. Set Monitor Components: 

 
There are two ways to set the monitor components. 
 
• Select monitored components in the GUI 

1) Select the Menu item "from GUI" under the menu "Analysis"->"CPFLOW 
Initial"->"Set Monitor" to activate this function. 

2) Click on the desired buses or branches on the one-line diagram to set the 
monitored components. 
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Note: The program treats the generation, the substation and the distributions center 
as a group of buses. When one of these components is clicked, a dialog box that 
lists all the buses in the group pops up and allows the user to choose the monitored 
bus from the group. 
 

• Enter the monitored bus from a dialog box. 
 

1) Select the Menu item "from Dialog Box" under the menu "Analysis"-
>"CPFLOW Initial"->"Set Monitor" to activate the following dialog box. 

 

 
Figure 3.7  Setting up monitored buses 

 
2) Enter the monitored bus numbers, separated by commas, and click OK. Note: 

The maximum number of monitored buses is 8. 
3) The other way to enter monitored buses is through a bus browser window that 

is shown as follows. A bus browser lists all the buses in the system and is 
activated by clicking on the browser button in the above dialog box. A user is 
able to select one bus or a set of buses from this window and click start to 
append the selection to the monitored bus window.  

 
3. Run Analysis 

 
Select "Run Analysis" under the menu "Analysis" to start the analysis. 
During the analysis, the program does the following three tasks: 
• It draws P-V curves for the monitored buses.  

 
Figure 3.8  P-V curve for constant PQ load model 
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• It generates a process bar and colors it green to indicate where the system is. When 

the program find a maximal lambda value which corresponds to the nose point in P-V 
curves, the lambda value will be displayed in the bar area. If that value is less than 
1.0, the program colors the remaining area of the bar in red to indicate that the system 
is unable to conduct the proposed transactions. 

• The power flow information for the monitored buses and branches is stored in the 
files "bus.dat" and "brn.dat" under the same directory where the project files are. 

3.4 CPFLOW Post-Processing and Output Analysis 
In this section, we describe the output analysis and post-processing capability of CPFLOW. 

3.4.1 General Output 

1. The power flow information for the monitored buses and branches is stored in files "bus.dat" 
and "brn.dat" under the directory C:\CPGUI. 

2. The P-V curves generated by the program are shown on the screen. 
3. The cross sign "×" on the P-V curve indicates that a voltage violation at some buses occurs at 

the operating point. Double-clicking on the sign will trigger a new window that lists all the 
buses experiencing a voltage violation. 
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Figure 3.9  List of buses with violations 
 

4. Double-clicking on an area other than the sign "×" opens a window that displays the ATC 
determined by the nose point and the ATC limited by the voltage violation. 

 

 
 

Figure 3.10  ATC information 
 

3.4.2 ZIP Load 
Load models are known to have a profound impact on power system behavior. The nonlinear 
load model, a ZIP-model is a combination of constant current, constant power, and constant 
impedance. This version of the CPFLOW program can generate ZIP-V curves to quantify the 
impacts of a particular load model on the overall loadability. ZIP-V curves represent power 
system quasi-steady-state behaviors as all the values of constant Z, I, P-Q (ZIP) vary and their 
variations are uniform. The ZIP-V curve can become an I-V, Z-V, IP-V, ZP-V or IZ-V curve 
when the values of the corresponding component are kept constant. 
 
Under the same test power system and using the same transaction proposed in the above, we 
have computed loadabilities for the following three different load models: CI, CZ, and ZIP load 
of 20% constant PQ, 20% constant current, and 60% constant impedance. Here the short form 
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CP stands for constant PQ load, CI stands for constant current load, CZ stands for constant 
impedance load and ZIP stands for a load combination of the above three load models. Three 
extra ZIP-V curves, along with a table summarizing the impact of the load model, are obtained 
and are given as follows. 
 

 
Figure 3.11  I-V Curve for CI load  

 
 
 
 

 
Figure 3.12  Z-V Curve for CZ load 
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Figure 3.13  ZIP-V curve for ZIP load 

 
 
 

Table 1: Load Model Impact  
 

 CP CI CZ ZIP 
ATC by nose 

point 4005 MW 4020 MW 4037 MW 4027 MW 

 

3.5 Miscellaneous Usage Information 
This section contains basic information about the appearance of the CPFLOW program screen 
and using the CPFLOW program. 

3.5.1 Tips for Operating the GUI 

1. The commands to enable or disable several information windows are under the Window 
menu. These information windows include the Message Window, Curve Window, 
Transaction Window, Monitor Window, and other windows. 

2. The commands to show or hide different types of components of the one-line diagram are 
under the Component menu. 

3. The commands to verify the one-line diagram of a power system are under the Verify menu. 
4. The commands to display the power flow results on the GUI are under the Result menu. 
5. Short-cut buttons have been created to ease operations. The "Bus" Button activates a quick 

search dialog box that is used to search branch, generator, load nodes, shunt capacitor, and 
text, on the one-line diagram or in the power flow data file. The "PF', "BuV", "LiF", "LoF' 
and "BuN" Buttons display the power flow information on the GUI, where PF stands for 
power flow, BuV stands for bus voltage, LiF stands for line flow, LoF stands for load flow, 
and BuN stands for bus number. 



 

 24

3.5.2 Starting the CPFLOW Program 

The first screen is the introductory screen, giving the program title and copyright information. To 
enter the program, click “OK”. To exit the program, click “EXIT”. 
 
The maps used are internal company copies of maps depicting all relevant information within a 
geographical section of territory. The maps may be modified through the use of the menu bar and 
the control bar. 

3.5.3 Menu Bar 
The Menu Bar runs across the top of the CPFLOW window and contains the menus and sub-
menus from which you can choose commands.  

3.5.4 File Menu 
Basic commands for opening, saving, printing, importing material into, and closing CPFLOW 
documents are located under the File menu. 

3.5.5 Opening a CPFLOW File 
Before a document is opened, the program screen will be completely blank, with the Menu Bar 
and Control Bar buttons at the top. To open a CPFLOW file, select “Open” from the File menu. 
The shortcut key F6 (“Open”) may also be used. 
 
Once “Open” has been selected, the Open dialog box will appear. This box is a standard 
Windows box, allowing the user to specify the file location, name and type. Once the correct file 
has been selected, click on the “Open” button. 

3.5.6 Creating a CPFLOW File  
To create a CPFLOW, select “New” from the File menu. The shortcut key F5 (“New”) may also 
be used. 

3.5.7 Saving a CPFLOW File 
There are two options for saving a file. The first, “Save”, is used when there are no changes to 
the name or location of the document. The shortcut key F2 (“Save”) may also be used. The 
“Save As” command is used to name and save a new file or to save an existing file under a new 
name or at a different location. The “Save As” command also allows the user to maintain a copy 
of the original file without the changes. The shortcut key F3 (“Save As”) may also be used. 

3.5.8 Closing a CPFLOW File 
Chose the command “DB Close” under the “File” menu. The shortcut key F4 (“DB Close”) may 
also be used. If changes have been made, the program will ask if the user wishes to save the 
changes or close the program without saving any changes. Any unsaved changes will be lost. 

3.5.9 Importing a Graphic 

The Graphic Import command is used for bringing graphic information into a CPFLOW 
document. From this menu item, a sub-menu listing the available formats opens. Clicking on a 
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format will bring up a window with the import setting specifications. Currently, only the 
exported file from our digitalization program can be imported. 
 
Example: Selecting the Gra Format submenu from the Graphic Import command opens a 
window with the heading “Import Setting”. Within this window, the user can select the specific 
settings desired. Under the sub-heading “File Path,” the user may type in a File Path and a 
Symbol File, or may click on the “Browse” button to browse available options. Under the sub-
heading “Transfer Convention,” the categories “Layer” and “Symbol” are set at a default of 
“Restall,” but may be modified if the user desires. The third option under this sub-heading is 
“Available Symbol”. The user may open the list of possible symbols by using the arrow on the 
right-hand side of the category. Available symbols are:  

• Arrow  
• Both_Arrow  
• Bus  
• Dc-converter  
• Dc-line  
• Distribution  
• End_Arrow  
• Fix_shunt  
• Fix-series-capacitor  
• Generation  
• Generator  
• Graphic-line  

• Line  
• Load  
• Off-switch  
• On-switch  
• Service  
• Stp  
• Substation  
• Switched-series-capacitor  
• Switched-shunt  
• Text  
• Transformer  
• Ultc-transformer  

 

3.5.10 Importing Data 
The Import Data command is used for bringing existing power flow data into a CPFLOW 
document. From this menu item, a sub-menu listing the available formats opens. These formats 
are: 

• PSF Format 
• PTI Format (Under the PTI Format, there are two options: “under 23” or “24 and up”) 
• IEEE Format 
• EPRI Raw 
• EPRI His 
• BPA Format 
• PECO Format 
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3.5.11 Printing a CPFLOW File  

The “Print” command prints the current CPFLOW file. The shortcut key sequence “Ctrl + p” 
may also be used. 
 
NOTE: At the present time, this feature does not function. 

3.5.12 Adjusting the Printer Settings 

The “Set Print” command brings up a dialog box containing the printer settings, including the 
printer chosen, the format for printing, and the number of copies. The shortcut key sequence 
“Ctrl + s” may also be used to open this dialog box.  

3.5.13 Exiting CPFLOW  
Choosing this menu item exits the program. If changes have been made, the program asks if the 
user wishes to save before exiting. Any unsaved changes will be lost 

3.6 Menus and Control Bar 

3.6.1 Edit Menu 
NOTE: At the present time, the Edit Menu features do not function. 
 
The commands under the “Edit” menu are used to modify a graphic object in the window. Some 
of them are the same as the commands in the buttons across the Control Bar, and the Control Bar 
buttons will register as activated when the commands are activated using the edit menu. 
Commands may also be deactivated by clicking on the Control Bar buttons rather than through 
the use of the edit menu items. 

3.6.1.1 Deleting a Device 

To delete a device, select “Del” from the edit menu or use the “Delete” button from the Control 
Bar and then click on the device to delete. The cursor will change from an arrow to a cross when 
the cursor is on a device. After clicking on the device, the program will ask whether or not the 
user actually wants to delete the device. Click “Yes” to delete and “No” to leave the device 
where it is. The “Del” feature remains active even if the answer is “No.” To deactivate this 
feature, click on “Del” again. Devices may also be deleted using commands on the Control Bar. 

3.6.1.2 Moving a Device 

In order to move a device, select “Move” from the edit menu or use the “Move” command button 
from the Control Bar and then click on the device to move. The cursor will change from an 
arrow to a cross when the cursor is on a device. After clicking on the device, the device and all 
connecting lines will be shown in yellow. The user may then drag the device, with its attached 
lines, to its new position and click again to set it in place. The colors will then return to normal. 
To deactivate this feature, click on “Move” again. Devices may also be moved using commands 
on the Control Bar. 
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3.6.1.3 Copying a Device 

In order to copy a device, select “Copy” from the edit menu and then click on the device to copy. 
The cursor will change from an arrow to a cross when the cursor is on a device. The device 
chosen and its copy will turn yellow to indicate their location. The user may then drag the copied 
device to its new location and click again to set it in place. The original device remains yellow, 
indicating that the “Copy” feature remains active. Clicking again on the original or its copy will 
produce another copy of the original device. To deactivate this feature, click on “Copy” again. 
Devices may also be copied using commands on the toolbar. 

3.6.1.4 Replacing a Device 

At present this feature is not available. 

3.6.1.5 Restoring Settings to Normal 

This feature resets the current editing state. 

3.6.1.6 Redrawing 

This feature refreshes the screen. 

3.6.1.7 Removing a Point 

This feature removes a point from a line of multiple points. 

3.6.1.8 Removing a Link 

This feature detaches a graphic object from its underlying power flow record. 

3.6.1.9 The Color Palette 

This command is used to display or remove a color palette window. Selecting this command 
brings up a palette display in the lower left-hand screen, with a selection of colors. The palette 
remains in place until removed through the use of the edit menu command or the shortcut key 
F8.  

3.6.2 Analysis Menu 
The commands under the “Analysis” button indicate the various types of action-related analysis 
that may be carried out.  

3.6.2.1 Power Flow Settings 

Power Flow Settings: Clicking on this menu item produces a window containing the information 
for the System Analysis Settings. These settings may be modified. This feature may also be 
accessed through the use of the shortcut key F9. 
 
CPFLOW Initial  

• Set Transaction: 
! Graphic: This feature may also be accessed through the use of the shortcut command 

Alt + F2 
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! Dialog Box: This feature may also be accessed through the use of the shortcut 
command Alt + F3 

• Set Monitor: 
! From GUI: This feature may also be accessed through the use of the shortcut 

command Alt + F5 
! From Dialog Box: 

• Unselect All: This feature closes the analysis menu and its submenus. 

3.6.2.2 Run Analysis 

This feature may also be accessed through the use of the shortcut key F10.  

3.6.3 Verify Menu 
The verify menu is used to confirm results. 

3.6.3.1 Verifying Connectivity 

Clicking on this sub-menu will call up the Verify Result window, listing the number, the 
component status, and the reason. To run the verification, click on the “Start” button at the 
bottom of the window. To close the window, click on the “X” in the upper right-hand corner. 

3.6.3.2 Verifying Linkage 

Clicking on this sub-menu will call up a “Select Element” window, listing the possible elements 
for this feature. The elements are: Bus, Fix Shunt, Fix Series Capacitor, Generation, Generator, 
Line, Load, STP, Substation, Switched Series Capacitor, Switched Shunt, Transformer, and 
ULTC Transformer. Click on the desired element and then click “OK.” The search result 
window will list the component, the starting bus, the end bus, and the ID. The search may be run 
to locate graphics or data; the choice may be made by selecting “Graphic Locate” or “Data 
Locate” from the bottom of the search result window. To remove the Search Result window, 
click on the X at the upper right-hand corner of the window. 

3.6.3.3 Returning to the Original Position 

The “New Scope” command returns the view shown in the larger portion of the screen to the top 
left of the map (blank). The “Panorama” view, if present, remains the same. The view may be 
changed by clicking within the panorama box and moving the rectangle or by using the scroll 
bars on the side and bottom of the screen. 

3.6.4 Window Menu 

The Window Menu is used to make modifications to the display window of the CPFLOW 
Program. Features that are activated, such as the Panorama Map and the Control Bar, are marked 
with a check. 

3.6.4.1 Adding or Removing the Control Bar 

The Control Bar is the selection of buttons located at the top of the map. Many of the buttons 
represent shortcuts to features found under the Edit menu. The control bar may be added or 
removed by clicking on the “Control Bar” command under the Window menu. 
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3.6.4.2 Adding or Removing the Panorama Map 

The Panorama map is a small box in the lower right-hand corner of screen, which provides an 
overview of the entire map area. The red rectangle in the panorama display surrounds the area 
currently displayed on the larger portion of the screen; it may be moved by placing the arrow 
within the red rectangle, holding down the left mouse key and “dragging” the rectangle to the 
desired position. The panorama can be removed or brought back by clicking on the “Panorama” 
command under the Window menu. For faster access, there is also a “Map” button on the 
Control Bar that may be clicked to add or remove the panorama feature. 

3.6.4.3 Adding or Removing the Active Layer 

The Active Layer feature may be added or removed by clicking on the “Active Layer” command 
under the Window menu. 

3.6.4.4 Viewing the Cursor Position 

Activating the “Cursor Position” feature pulls up a numerical representation of the exact cursor 
position on the map, located to the right of the Control Bar. As the cursor is moved within the 
map, the numerical position representation changes. This feature may be added or removed by 
clicking on the “Cursor Position” command under the Window menu or by using the shortcut 
command Alt + c. 

3.6.4.5 Adding or Removing the Message Window 

The “Message Window” command brings up a small PFlow Result Message window within the 
map. This feature may be added or removed by clicking on the “Message Window” command 
under the Window menu or by clicking to close the PFLOW Result Message window itself. 

3.6.4.6 Adding or Removing the Curve Window 

The “Curve Window” command brings up a small P-V Curves graph window within the map. 
The x-axis of the graph represents the P(Lambda) value and the y-axis represents the Voltage 
(p.u.), expressed in values ranging from 0.000 to 1.818. This range will be adaptively adjusted to 
fit real curves once they are drawn. An example is shown above in Figure 3.8. Double-clicking 
on the graph itself brings up another window displaying ATC Results that shows the maximum 
ATC and the load margin limited by SN for the system. To close the ATC Results window, click 
on the X at the top right-hand corner of the window. To close the P-V Curves graph, click on the 
Curve Window command under the Window menu or on the X at the top right-hand corner of 
the P-V Curves graph window. 

3.6.4.7 Adding or Removing the Transaction Window 

Clicking on the “Transction Wnd” command brings up a small Proposed Power Transaction 
window within the map. To close the Proposed Power Transaction window, click on the 
Transaction Window command under the Window menu or on the X at the top right-hand corner 
of the P-V Curves graph window. 



 

 30

3.6.4.8 Adding or Removing the Monitor Window 

Clicking on the “Monitor Wnd” command brings up a small Monitored Components window 
within the map. To close the Monitored Components window, click on the “Monitor Wnd” 
command under the Window menu or on the X at the top right-hand corner of the Monitored 
Components window. 

3.6.4.9 Performing Bus Searches 

In order to perform a bus search, click on the “Search Bus” command under the Window menu 
or use the shortcut command Alt + b. The “Search Bus” feature is also available through a 
command button on the Control Bar. Activating this feature brings up a “Quick Search” window 
within the map. The Quick Search window contains a list of features within which a search can 
be made. These features include: branch, generator, load, nodes, shunt, and text. To select a 
feature, click on it so that it is highlighted. Once a feature has been highlighted, the right side of 
the window displays a list of search mode criteria that can be adjusted. These criteria vary 
according to the feature that has been highlighted: 

• Branch: The search mode can be either “Graphic” or “All Data.” There is a space for 
inputting the first bus (“From Bus”) and the last bus (“To Bus”). Both buses can be 
adjusted to run with “Auto,” “Name,” or “Number” as the determining factor. 

• Generator: The search mode can be either “Graphic” or “All Data.” There is a space for the 
bus name, and the bus selected can be adjusted to run with “Auto,” “Name,” or “Number” 
as the determining factor. 

• Load: The search mode can be either “Graphic” or “All Data.” There is a space for the bus 
name, and the bus selected can be adjusted to run with “Auto,” “Name,” or “Number” as 
the determining factor. 

• Nodes: The search mode can be either “Graphic” or “All Data.” There is a space for the bus 
name and for the voltage involved. The bus selected can be adjusted to run with “Auto,” 
“Name,” or “Number” as the determining factor. 

• Shunt: The search mode can be either “Graphic” or “All Data.” There is a space for the bus 
name, and the bus selected can be adjusted to run with “Auto,” “Name,” or “Number” as 
the determining factor. 

• Text: The “Text” search mode provides a space to type the text that is being searched for. 
 
Once the search features have been properly set, the search results will be displayed in a “Verify 
Results” window. Information will be displayed for several categories, including Component, 
From/End Bus or Bus Name, and ID. The “Verify Results” window can be closed by clicking on 
the X in the upper right-hand corner. To turn off “Search Bus,” either click on “Search Bus” 
within the Window menu, use the short-cut command Alt + b, or click on the “Search Bus” 
command button on the Control Bar. To run another search, the “Search Bus” feature must be 
turned off and then turned back on again. 

3.6.4.10 Obtaining Information 

Information can be obtained about the following components: Bus, Fix Shunt, Fix Series 
Capacitor, Generator, Graphic Line, Line, Load, STP, Switched Series Capacitor, Switched 
Shunt, Text, Transformer, and ULTC Transformer. To access information concerning these 
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components, choose “Information” from the Window menu. Each component displays a different 
set of informational criteria: 

• Bus: 
• Fix Shunt: (Not Available) 
• Fix Series Capacitor: (Not Available) 
• Generator: (Not Available)  
• Graphic Line: (Not Available) 
• Line: 
• Load: (Not Available) 
• STP: (Not Available) 

• Switched Series Capacitor: (Not 
Available) 

• Switched Shunt: (Not Available) 
• Text: (Not Available) 
• Transformer: (Not Available) 
• ULTC Transformer: (Not Available) 

 

3.6.4.11 Returning to Previous Status (not available) 

3.6.4.12 Adding or Removing the Zoom Box (not available) 

3.6.5 Results Menu 
Before any of the items within this menu can be run, a regular power flow must be run first.  

3.6.5.1 Power Flows 

This feature can also be accessed through the use of the “PF” command button on the Control 
Bar. It displays the power flow result on the screen if it is a one-line drawing. It contains diagram 
of the system with linkages to the underlying power flow data. 

3.6.5.2 Bus Voltages 

This feature can also be accessed through the use of the “BuV” command button on the Control 
Bar. It contains a diagram of the system with linkages to the bus voltages in the underlying 
power flow data. 

3.6.5.3 Line Flows 

This feature can also be accessed through the use of the “LiF” command button on the Control 
Bar. It contains diagram of the system with linkages to the line flow information in the 
underlying power flow data. The arrow over the data represents the direction of the real power 
flow. 

3.6.5.4 Load Flows 

This feature can also be accessed through the use of the “LoF” command button on the Control 
Bar. It contains diagram of the system with linkages to the underlying power flow data and 
displays the power flow injected into or from a bus from a generation or load.  

3.6.5.5 Power Flow Summary 

This feature may also be accessed through the use of the shortcut keys.  
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3.6.6 Query Menu 

3.6.6.1 Query Elements 

This feature may also be accessed through the use of the shortcut command Ctrl + e. 

3.6.6.2 Query Results 

Results can only be queried after a simulation has been run. This feature may also be accessed 
through the use of the shortcut command Ctrl + r. 

3.6.7 Component Menu 
The component menu contains a list of all of the components present within the map display. 
Each component currently shown on the screen is marked with a check. To add or remove 
components, click on the component name within the list or use a shortcut command. Any 
configuration of components may be displayed. 

3.6.7.1 Bus 

Buses are represented on the map by empty circles or squares with solid center circles. Buses 
may also be added or removed through the use of the shortcut command Shift + b. 

3.6.7.2 Line  

Lines are represented on the map by colored lines. Lines may also be added or removed through 
the use of the shortcut command Shift + l. 

3.6.7.3 Switch  

Switches may also be added or removed through the use of the shortcut command Shift + s. 

3.6.7.4 Generator  

Generators are represented on the map by circles with solid center circles. Generators may also 
be added or removed through the use of the shortcut command Shift + r. 

3.6.7.5 Shunt  

Shunts may also be added or removed through the use of the shortcut command Shift + v. 

3.6.7.6 Transformer 

Transformers may also be added or removed through the use of the shortcut command Shift + t. 

3.6.7.7 Map  

The use of the “Map” command adds or removes all geographic references, shown in white, 
from the screen. Geographic references may also be added or remove through the use of the 
shortcut command Shift + m. 
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3.6.8 Option Menu 

The option menu provides an opportunity to adjust map display options.  

3.6.8.1 View 

Clicking on the “View” command under the Option menu brings up the “View Option” window. 
This window contains the controls for adjusting color and margins within the CPFLOW display. 
Options whose color can be adjusted include: Select Color, Highlighted Color, Background 
Color, Flash Color, Outage Color, Label Color, and View Frame, Options whose measurements 
can be adjusted include Margin and Fuzzy Dis. Clicking on any of the colors shown for the 
categories brings up the palette of colors available to select from. 

3.6.8.2 Layer 

Clicking on the “Layer” command under the Option menu brings up the “Layer Control” 
window. The list of layers represents every component present in the CPFLOW map displayed. 
At the top of the window, the number of the current component selected is displayed. To select a 
component, click on it within the list. Once a component has been selected, it can be modified. If 
the component is currently on, it can be turned off by clicking the “Off” button on the right side 
of the window. Once the “Off” button has been clicked, it becomes an “On” button and may be 
used to reactivate the component. The display color of the component selected can be changed 
by clicking on the “Color” button on the right side of the window. Clicking the “Color” button 
brings up the color palette selection. Clicking on a color selects that color. As a shortcut to turn 
all components on or off simultaneously, there are “All On” and “All Off” buttons. At the bottom 
of the “Layer Control” window are buttons for creating a new layer or renaming an existing 
layer, along with a text input window to type the new name. Once the settings have been 
changed, click “OK” to close the window and accept the new settings or “Cancel” to close the 
window without any changes having been made. 

3.6.9 Help Menu 
The “Help” menu is designed to provide assistance and information to CPFLOW users. 

3.6.9.1 About DSA/G 1.0… 

Selecting this item brings up a window containing basic information about the program. This 
feature may also be accessed through the use of the shortcut command Alt + a 

3.6.9.2 Help Index 

Note: This feature is not currently available.  
 
This feature may also be accessed through the use of the shortcut key F1. 

3.6.10 The Control Bar 
The Control Bar runs across the top of the map. This feature is listed under the “Window” menu 
in the main menu bar. When it is present, it is marked with a check to the left of the menu item. 
It can be removed or brought back by clicking on the name “Control Bar.” The Control Bar 
contains buttons controlling various features relating to map display. These include: 
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3.6.10.1 Search Bus 

The “Search Bus” button brings up the “Quick Search” window, which offers the user a variety 
of search options. Searches can be made within the functions of Branch, Generator, Load, Nodes, 
Shunt, or Text. To select a feature, click on it so that it is highlighted. Once a feature has been 
highlighted, the right side of the window displays a list of search mode criteria that can be 
adjusted. These criteria vary according to the feature that has been highlighted: 

• Branch: The search mode can be either “Graphic” or “All Data.” There is a space for 
inputting the first bus (“From Bus”) and the last bus (“To Bus”). Both buses can be 
adjusted to run with “Auto,” “Name,” or “Number” as the determining factor. 

• Generator: The search mode can be either “Graphic” or “All Data.” There is a space for the 
bus name, and the bus selected can be adjusted to run with “Auto,” “Name,” or “Number” 
as the determining factor. 

• Load: The search mode can be either “Graphic” or “All Data.” There is a space for the bus 
name, and the bus selected can be adjusted to run with “Auto,” “Name,” or “Number” as 
the determining factor. 

• Nodes: The search mode can be either “Graphic” or “All Data.” There is a space for the bus 
name and for the voltage involved. The bus selected can be adjusted to run with “Auto,” 
“Name,” or “Number” as the determining factor. 

• Shunt: The search mode can be either “Graphic” or “All Data.” There is a space for the bus 
name, and the bus selected can be adjusted to run with “Auto,” “Name,” or “Number” as 
the determining factor. 

• Text: The “Text” search mode provides a space to type the text that is being searched for. 
 
Once the search features have been properly set, the search results will be displayed in a “Verify 
Results” window. Information will be displayed for several categories, including Component, 
From/End Bus or Bus Name, and ID. The “Verify Results” window can be closed by clicking on 
the X in the upper right-hand corner. To turn off “Search Bus,” click on the “Search Bus” 
command button, “Search Bus” within the Window menu, or use the short-cut command Alt + b. 
To run another search, the “Search Bus” feature must be turned off and then turned back on 
again. 

3.6.10.2 Selecting an area 

The “Selecting” button allows the user to mark an area of the screen for modification. Setting the 
arrow key at one corner of the desired location and clicking the left mouse button will result in 
the creation of a box, defined by yellow lines. Surround the feature that needs to be selected and 
click the left mouse button. The selected feature(s) and the connecting lines will be highlighted 
in yellow. The size of the box will change as the cursor is moved. Click again to remove the 
highlighting and start a new box. Clicking on the left mouse button when no features are in the 
box will eliminate the box appearing on the screen and establish the cursor as the point of origin 
for a new box. Clicking on the right mouse button will eliminate the box and disengage the 
“Selecting” feature. To turn off the “Selecting” function, click on the Control Bar button.  
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3.6.10.3 Moving a Device 

Once an area has been selected, it may be moved. Select the “Move Device” command button 
from the Control Bar. Move the cursor to the selected device and click once with the left mouse 
button. When the cursor is on the device, the arrow will change to a cross. Next, drag the item to 
the desired position and click the left mouse button again. The attached lines will move along 
with the device selected. To turn the “Move Device” function off, click on the Control Bar 
button or click “Move” from the Window menu. 

3.6.10.4 Copying a Device 

Once a device has been selected, it may be copied. When the cursor is on the device, the arrow 
will change to a cross. Move the cursor to the selected item and click once with the left mouse 
button. A duplicate of the item will appear and may be moved to any point in the diagram. When 
it is in the desired position, simply click the left mouse button again to position it. The device 
will remain highlighted and other copies can be made. To remove the highlighting, click on the 
“Selecting” button.  

3.6.10.5 Delete Device  

Once a device has been selected, it may be deleted. Simply click on the “DEL” button on the 
toolbar. A screen will appear, asking if you are certain that you wish to delete the device. If “No” 
is clicked, nothing will happen. If “Yes” is clicked, then the device will be deleted. 

3.6.10.6 Replace Color 

Note: This feature is not currently available. 
This feature replaces the color of a selected line when that line is clicked on. Click on the “REP” 
button to activate this feature. 

3.6.10.7 Remove Point 

This feature removes a point when it is selected and clicked on. Click on the button with the 
Remove Point symbol (to the right of the “REP” button) to activate this feature. 

3.6.10.8 Remove Link 

This feature is used to remove a selected link from the map. Click on the button with the Remove 
Link symbol (to the right of the Remove Point button) to activate this feature. Once a link has 
been selected and clicked on, the program will ask if you are certain that you wish to remove this 
link. If “No” is clicked, nothing will happen. If “Yes” is clicked, then the link will be removed. 

3.6.10.9 Panorama  

The panorama is a small box in the lower right-hand corner of screen, which provides an 
overview of the entire map area. Clicking on the “MAP” command button will open or close the 
panorama option. The red rectangle in the panorama display surrounds the area currently 
displayed on the larger portion of the screen; it may be moved by placing the arrow within the 
red rectangle, holding down the left mouse key and “dragging” the rectangle to the desired 
position. The panorama feature is also listed under “Window” in the main toolbar. 
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3.6.11 Normal System 

3.6.11.1 Update View 

(Note: in order to use the following features, a regular power flow must be run first) 

3.6.11.2 Power Flow 

This feature can also be accessed by clicking on “Power Flows” under the Results menu. 

3.6.11.3 Bus Voltage 

This feature can also be accessed by clicking on “Bus Voltages” under the Results menu. 

3.6.11.4 Line Flow 

This feature can also be accessed by clicking on “Line Flows” under the Results menu. 

3.6.11.5 Load Flow 

This feature can also be accessed by clicking on “Load Flows” under the Results menu. 

3.6.11.6 Bus Name 

When a one-line diagram containing buses is displayed on the screen, clicking on this feature 
will cause the bus names to appear on the screen or be removed from the display. 
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Chapter 4 
Future Research and Software Development 

CPFLOW can be used in a variety of applications such as:  
• monitoring voltage behaviors due to load and generation variations to detect such 

problems as voltage dip and collapse 
• evaluating maximum interchange capability 
• evaluating maximum available transfer capability 
• tracing of power system behaviors due to load and/ generation variations with/without 

control devices 
• conducting coordination studies of control devices for steady-state security 

enhancements 
• evaluating the effects of different load models on voltage stability, transfer capability 

among other system condition variables of interest. 
It is imperative in these applications to take into account all credible contingencies. At present, 
CPFLOW can be ineffective in doing so for all credible contingencies. The strategy of using 
effective schemes to rank all credible contingencies and of applying detailed analysis programs 
only to critical contingencies is widely accepted. In order to identify critical contingencies which 
will severely violate security constraints, we suggest the development of look-ahead ranking 
schemes and the incorporation of these schemes into CPFLOW. 
 
We consider the following situation given (i) the current operating condition (obtained from the 
state estimator and the topological analyzer), (ii) a set of proposed power transactions, and (iii) a 
list of credible contingencies. For each credible contingency, we suggest the development of 
three look-ahead schemes for estimating the load margins between the current operating point (in 
the load-generation space), along the proposed power transaction vector b, to the following three 
limiting operating points respectively: the steady-state stability limit (nose-point load margin), 
the bus voltage limit point, and the line flow thermal limit point of the power system with the 
proposed power transactions. In other words, the three look-ahead schemes estimate the 
following: 

• the nose-point load margin for each contingency to measure the distance (in MW and/or 
MVAR) between the current operating condition and the nose point of the parameterized 
power system subject to the contingency; 

• the voltage-limit load margin for each contingency to measure the distance (in MW 
and/or MVAR) between the current operating condition and the state vector, at which 
the voltage constraint at some bus is violated of the parameterized power system subject 
to the contingency; and 

• the thermal-limit load margin for each contingency to measure the distance (in MW 
and/or MVAR) between the current operating condition and the state vector, at which 
the thermal limit constraint of some transmission line is violated of the parameterized 
power system. 
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